本站所有文章均为原创,如对您有帮助,恳请帮忙点击任何一处广告
  • 首页
  • Apache
  • LAMP环境搭建——编译安装APACHE 2.4

LAMP环境搭建——编译安装APACHE 2.4

发布:TangLu2015-7-16 17:36分类: Apache 标签: LAMP apache httpd

在安装APACHE 2.4之前,需要确认系统已经安装了pcre(用于实现正则功能)apr1.4和apr-util1.4相关运行环境(Centos6开始已经默认安装了apr和apr-util的,一般不需再做操作)


yum -y install pcre-devel    #安装pcre组件

tar zxf apr-1.4.6.tar.bz2    #安装apr
cd apr-1.4.6
./configure --prefix=/usr/local/apr
make && make install

tar xf apr-util-1.4.1.tar.bz2    #安装apr-util
cd apr-util-1.4.1
./configure --prefix=/usr/local/apr-util  --with-apr=/usr/local/apr
make && make install


编译安装apache 2.4,自带了很多选项,这里的选项已经够生产环境使用,如果要在安装完后查看之前编译安装时所用的选项,可以查看build目录下的config.nice文件


tar zxf httpd-2.4.tar.gz
cd httpd-2.4
./configure 
--prefix=/usr/local/httpd \
--sysconfig=/etc/httpd \
--enable-so \ 
--enable-rewrite \
--enable-ssl \
--enable-cgi \
--enable-cgid \ 
--enable-modules=most \
--enable-mods-shared=most \ 
--enable-mpms-shared=all \
--with-apr=/usr/local/apr \
--with-apr-util=/usr/local/apr-util
make && make install


 

启动apache,在安装目录的bin目录下有个apachectl脚本用于管理apache

httpd2.4.png

 

通过httpd -l和httpd -M两个命令可以看到httpd启用的是event模块,如果要更换的话只需要修改httpd.conf里的LoadModule里的对应信息即可

httpd2.42.png

修改后再次查看,已经可以看到模块被修改为了prefork

httpd2.43.png

 

访问测试,It Works!!大功告成!

httpd2.44.png

温馨提示如有转载或引用以上内容之必要,敬请将本文链接作为出处标注,谢谢合作!
et_highlighter51
版权所有:《Linux运维技术学习站点
文章标题:《LAMP环境搭建——编译安装APACHE 2.4
除非注明,文章均为 《Linux运维技术学习站点》 原创
转载请注明本文短网址:http://www.linuxe.cn/post-222.html  [生成短网址]

已有 0/1812 人参与

发表评论:

欢迎分享Linux运维技术学习站点

欢迎使用手机扫描访问本站,还可以关注微信哦~